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What is SPRY News?
SPRY News is a news reader program allowing you to access news services on the Internet, 
featuring a straightforward, easy-to-use Windows interface allowing you to read, save, and 
post news articles.    
Many people with Internet access use Internet news services.    You can think of an Internet
news service as a large computer bulletin board which can be accessed over the Internet 
and used as a forum for conversation, discussion, and information exchange.    A news 
service contains newsgroups, discussion areas dedicated to topics both educational and    
recreational.
You can add to the discussion in a newsgroup by adding your message; this is called 
"posting".    Messages posted to Internet news services are called articles.    News is not only
a forum for discussion, it is a powerful medium of exchange; aside from discussions, news 
articles can contain binary files such as program files or source code.
How Do I Connect to News?
You connect to a news service by connecting to a News Server, a machine which uses the 
Network News Transfer Protocol (NNTP) to access USENET or another news service.    
Although many News Servers may have access to the same news service (the USENET is the
most common), not all News Servers will necessarily have all available newsgroups.    The 
administrators of News Servers can choose which newsgroups to allow on their News 
Servers; some businesses do not allow recreational newsgroups, for instance.    Thus, you 
may find different newsgroups on different News Servers, even though they may both be 
drawing from the same large pool of newsgroups.  
What News Server Do I Use?
SPRY News comes pre-configured with its own News Server address, so you can immediately
begin to explore USENET news.    SPRY News will automatically connect to this News Server.   
You can also configure SPRY News to connect to any other News Server you choose.
You can also choose to connect to a different News Server, if you know a News Server to 
connect to using the <Startup Options> dialog.    You can also change news servers at any 
time using the Change Server command.
____
See
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Starting News
You start News by clicking on the News icon.    When you start News, it will immediately start 
connecting you to the pre-configured news server, so that you can begin working (or 
playing) with News.     
You will see the News Console .
The News Status Bar (at the bottom of the Console) will read "Trying to connect to <News 
Server>", and then, after a connection is established, the message "Connected to <News 
Server name and information>".    You are then connected to the news server. 
The first time you start News, you will see the Newsgroup Browser.    You may also see a 
number of Personal Groups, collections of related newsgroups.    (Once you're familiar with 
News and USENET news, you can create your own Personal Groups; see Personal Groups for 
information on creating and using Personal Groups.)
You can immediately begin opening the newsgroups and reading news articles.
Note: You can disconnect from a News Server at any time by choosing Disconnect from the File menu.

____
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Working Off-Line
You can work off-line in SPRY News.    This feature is most useful when using News over a 
SLIP or PPP dialup account.    When you wish to work off-line, choose the Disconnect option 
in the File menu. To save connect charges, be sure to disconnect the Dialer application, as 
well.    Working off-line is designed to allow you to perform administrative functions without 
incurring connect charges with your Internet Service Provider.    The most common off-line 
functions you might perform include creating and updating personal groups (subscribing and
unsubscribing to newsgroups), examining the Newsgroup Browser, setting preferences and 
options, and performing searches.    While off-line, you can also compose posts, follow-ups, 
and replies, although you must reconnect before sending.

When you are working off-line, you can only work with the elements you see on your screen. 
In other words, you may scroll through the list of articles in a newsgroup while off-line, but 
you cannot open and read articles while off-line.    If you doubleclick on an article to read it 
while off-line, News will try to reconnect to your News Server.    If you have selected the 
option Prompt Before Reconnect from the <Other> dialog, News will prompt you and ask if 
you would like to reconnect to your server.    It is recommended, if you plan to work off-line, 
that you select this option or have the same option set in the Dialer, so that you will know 
when News is reconnecting.

You can connect News again by choosing Connect in the File menu; this will be available 
only when you are disconnected from News.

Warning! If you are working off-line to save dialup connection charges, be sure you 
disconnect the Dialer application, as well as News.    The Disconnect button in 
News does not automatically disconnect the Dialer, so charges can still be 
incurred.



The News Console
When you start News, you will see the News Console.
The Toolbar at the top of the News Console contains buttons that serve as shortcuts for 
News menu items.    The Toolbar style can be changed between Picture & Text, Picture only, 
and Text only by choosing Toolbar Style from the Options menu.
The Status Bar at the bottom of the Console displays concise help for News buttons and 
menu items and will display News status messages.
Both the Toolbar and the Status Bar can be shown or hidden by checking or unchecking 
Status Bar or Toolbar in the View menu.    The Toolbar and Status Bar will be displayed if 
checked.
Note: News menu items and buttons may be grayed out when a function cannot be performed. 



Browsing Newsgroups
News includes a Newsgroup Browser that allows you to browse through all the newsgroups 
on a News Server and view the articles in any newsgroup.    The Newsgroup Browser is 
automatically opened when you first open News; you can leave it open on your desktop, if 
you wish, or close it and only open it when you need to retrieve newsgroups.
To open the Newsgroup Browser:
Choose Newsgroup Browser in the Window menu.    You will see the Newsgroup Browser.
Note: Opening the Newsgroup Browser will take varying amounts of time, depending on how many newsgroups 

are found on the News Server you selected, and whether Auto Refresh is on.

When you first open the Newsgroup Browser, it lists all the newsgroups available on the 
News Server you are using, in list format.    This lists every newsgroup in alphabetical order 
from a-z.    
You can scroll through the list of newsgroups using the arrow keys or PageUp and PageDown 
keys, or scroll through them using the Windows scroll bar.    When you find a newsgroup that 
interests you, doubleclick on the newsgroup folder (you can also click the [Enter] key on 
your keyboard, or click Read in the Newsgroup menu.    This will display a list of all the 
articles in that newsgroup.    You can then read any of the articles you choose.
Tree mode is also available for the Newsgroup Browser.    This allows you to expand and 
collapse newsgroups, making browsing    easy and fast.    You can change from List mode to 
Tree mode (and back) using the Tree and List commands in the View menu.
When you have fully opened a newsgroup, the articles in that newsgroup will display in an 
article screen, and you can begin reading them.
You can also open any Personal Groups by doubleclicking on the newsgroup names 
displayed in the Personal Group screen (some Personal Groups may be minimized, just 
doubleclick on the minimized icons to open the Personal Groups).    This will display a list of 
all the articles in that newsgroup.    You can then read any of the articles you choose; see 
Reading Articles for a description of how to use the article screen.

____
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Newsgroup Browser Tree Mode
When you use the Newsgroup Browser in tree mode, you will first see only the general 
categories for newsgroups. (i.e. comp is the category for all the computer related    
newsgroups, like comp.lang.unix and comp.os.windows; seattle is the category for all the 
Seattle-based newsgroups, etc.)
Any folder displaying a + contains sub-categories.    These categories make up the 
newsgroup name.    In other words, to get to newsgroupalt.alien.visitors, you would open 
the folder alt then alien then visitors.



Reading Articles
When you open a Newsgroup in the Newsgroup Browser or from a Personal Group, you will 
see a "Transferring Article List" message, and a Status Bar indicator that will tell you how 
many articles are being read in.    The newsgroup window will appear.
The articles will initially display ordered by subject.    The newsgroup window fieldbar 
displays the article status, author, date, number of lines, and subject of the article.    You can 
change how the articles are sorted and which of these details are shown; see Displaying 
News Articles for more information.
Note: News also allows you to sort by threading; if this is the case, your screen will not display the fieldbar items.

You can now read an article by doubleclicking on the article name, choosing Read in the 
Article menu, clicking the Read button in the newsgroup window toolbar, or pressing 
Enter.    The article will open and display in a window.    You can read through the article 
using the Windows scroll bars at the edge of the screen or any of the standard Windows 
movement keys: Page Up, Page Down, the arrow keys, Home and End.
This window will be opened as a separate window from the newsgroup window.    If you want,
you can have the newsgroup window change into the article window.    In the <Options> 
dialog, accessed using Other in the Options menu, choose Use Newsgroup window to read 
article instead of the default, Open New window to read article.
____
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Navigating through Articles
You can navigate through articles as follows:
> Click the Back button to return to the article screen
> Click >> (or choose Next from the Article menu) to move to the next article in the 

article screen (the article below the current article)
> Click << (or choose Previous from the Article menu) to move to the previous article in 

the article screen (the article above the current article)



Catching Up
News includes a Catchup command that allows you to "catchup" in a newsgroup, marking 
all of the articles as "read" and hiding them from the display.    The Catchup feature is used 
so that you don't have to read through articles that you've already read; in cases of 
newsgroups with many hundreds of articles, you may wish to use this feature so that you 
can start "from scratch" to try to keep up with the volume of articles that are created every 
day.
To catchup a newsgroup, have the newsroup article screen open, and click the Catchup 
button on the article screen toolbar, or click Catchup in the Newsgroup menu. You will see 
a <Confirm Catchup> dialog asking you to confirm that you want to catchup.    The 
newsgroup you are currently reading will close; you are caught up.    The newsgroup is now 
"empty" (although the articles can be re-displayed); the next article(s) posted to that 
newsgroup after you use Catchup will appear at the beginning of that newsgroup.    
Note that if you have Show All Articles in the Newsgroup menu checked on, all the 
articles in the dialog will still display! You must disable this feature for Catchup to work.
If you try to open a caught up newsgroup, and no new articles have been added to the 
newsgroup, you will be presented with a <Caught Up> dialog that informs you that you are 
caught up in that newsgroup, and asks you if you want to open it anyway.    If you open the 
newsgroup anyway, the newsgroup will display as empty.
If you opened a caught up newsgroup, and decide that you do, after all, want to see those 
older articles, you can click Show All Articles in the Newsgroup menu to display all of the
articles that were hidden using the Catchup command.
You can, if you wish, turn off the Confirmation dialogs that appear when using Catchup or 
trying to open a caught up dialog.    In the <Other> dialog (accessed using Other in the 
Options menu), uncheck Confirm on Catchup or Confirm on open of caught up Newsgroup.



Confirm Catchup
This dialog asks if you are sure you want to catchup the current newsgroup.    All of your 
current articles, read and unread, will be hidden from view if you choose yes.    However, you
can display the messages at any time by choosing Show All Articles from the Newsgroup 
menu.
You can choose to not have this dialog display by checking Disable this message in the 
dialog.



Caught Up
This dialog will be displayed when you open a newsgroup that you previously caught up, that
has no new messages.    Since this newsgroup is currently "empty", you are asked whether 
you want to view the previous articles.    Click Yes to view the previous articles, or click No to 
open the empty newsgroup.    You can click Cancel if you did not really want to open the 
newsgroup.
You can choose to not have this dialog display by checking Disable this message in the 
dialog.



Refreshing Newsgroups and Articles
In USENET news, new newsgroups often appear and disappear; older articles expire and new
ones are continually added.    Because it takes some time to read in newsgroup and article 
information, you have the option of "refreshing" (updating) the newsgroup and article 
screens whenever you wish.    When you refresh the screen, any changes that have occurred 
will be updated; if you do not, you may find that you cannot open some (deleted) 
newsgroups, or that you don't see new articles in a newsgroup.
You can refresh the current newsgroup screen (Newsgroup Browser or Personal Group) or 
article screen by choosing Refresh from the Newsgroup menu.
If you want to refresh all screens upon opening, check Auto Refresh to automatically 
refresh the newsgroup listing when opening.    This process takes a little while (you will see a 
"Refreshing listbox" message in your Status Bar) but ensures that the news listings you see 
are accurate.    However, if you would prefer to list newsgroups faster, you can disable this 
option by unchecking it; this will lessen the time it takes to re-list all the newsgroups.    
(Note:    Newsgroup articles will automatically be refreshed when you open them).
You can choose Refresh from the Newsgroup screen at any time to refresh newsgroups in 
the window you have selected.



Displaying News Articles
You can change the font used in your News screen, and the header information that is 
displayed; click on the option below for information.
____
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Fonts
You can choose Fonts in the Options menu to change the news display text to different 
fonts, sizes and styles.    The News screen will resize after you change fonts.
You can change the font for the Newsgroup Browser, Newsgroup Lists, or Article screens.
Click Choose next to the option for which you want to change the font.    A Windows font 
dialog will appear allowing you to choose the font, font style, and font size to use when 
displaying lists or articles.



Choose Font
You can choose the font, font style, and font size you want to use for the item you selected, 
using this dialog.
You can choose any listed font name, size, or style.    The fonts and sizes available will vary 
according to the printer driver you are using.    You can use either proportional or non-
proportional fonts for your News screens.



Article Headers
News allows you to specify which news article header information to display.    This is 
information such as the news subject, author, newsgroups the article is posted to.
By default, all the header information will be displayed.    The information you see may vary 
according to the news program/host being used by the person posting the article.
You may not want to display the entire news header; you can decide which information you 
really want to see, and specify that just that information be displayed.    Click Article 
Headers to display the <Article Headers> dialog.
The selection All (display all header information) is checked on, by default.    You can select 
None to display no header information (unless you think you can tell who sent you mail by 
the content of their message, this option may not be helpful).    
To select which message headers you want to display, choose Selection:.    You will then be 
able to click on the items you want to display in the message header.    If you are not sure 
which items you will need, look at some of the messages you've received to determine what 
information you find useful.    The names of the items in the Selection field above should be 
the same (or very similar) to the actual header information you see.
When you have chosen the items you want to display, click OK. 
You will then see new headers on all news articles, displaying just the information you 
specified.



Threading
When you're reading USENET news, you will notice that many of the posted articles are 
responses to previously posted articles, and many are responses to those responses.    News 
keeps track of which articles are related to which others.    Threading  is a method that can 
be used to group those articles together, so that you can follow the sequence (the "thread") 
of an entire news conversation.    News supports threading with an easy-to-use graphical 
interface.
Click Sort by Thread in the View menu to change the current display to show articles 
sorted by thread.
Articles will be listed first in alphabetical order, and then will be listed by thread.    The first 
article in a thread (the "root" article) will be an article to which follow up articles were 
posted.    The follow up articles are considered part of the thread, and are listed under the 
root article in a tree structure.    Note:    the root article is not necessarily the first article ever 
posted about that particular subject; the original root of the thread may have expired 
already.
In a thread, there can be follow up articles to the root article, or there can be follow-ups to 
those follow-ups (it can get quite complex).    Thread links are shown in color to help you 
identify which article an article was following up to; the first level is black, the second blue, 
the third red, etc.
You can start reading any displayed article as you would normally displayed article.    You can
then then click >> in the article screen toolbar to move to the next article, it will move to 
the next article in that thread; when the thread is finished, it    until the thread is finished, 
and will then move to the next thread.    Likewise, clicking << will move you to the previous 
article in the thread,and then the previous thread.
Note: When you are displaying articles by thread, you will not see all of the information about the article listed on 

each line as you do in other displays; you will only see the subject of the root article, and the author of each 
follow up article.    If you highlight an article, however, you will see additional information listed in the Status 
Bar at the bottom of the screen.    This was done to keep the screen manageable (since all of the subjects of 
the thread are usually the same.

You can collapse or expand specific threads.    Collapsing an article thread hides all the 
follow-ups to that article, allowing you to ignore threads you're not interested in.    When you 
collapse a thread, a small triangle indicator below the article name reminds you that there 
are connected articles underneath.
Expanding will display any collapsed articles under a thread.    
Highlight the top of the thread that you want to collapse, and click Collapse in the article 
screen toolbar to hide all the connected threads.    To expand them again, doubleclick on the 
article name, or click Expand in the article screen toolbar.      If you want to expand all 
threads quickly, click Show All Articles in the Newsgroup menu. 
By default, all threads are expanded fully when you use Sort by Threading; if you want 
threads to stay collapsed until you open them, change the Open all Threads Initially option 
in the <Other> dialog (accessed using Other in the Option menu.



Saving Articles
You can save any currently displayed article to a text file using the Save As command.
Saving an article to a file:
1) Open the article.
2) Choose Save As from the File menu

or
Click the Save button on the Toolbar

You will be asked to specify a filename for the article.    The News program will suggest an 
extension of .txt.    Type a name, and click OK or press [Enter].    The article will be saved to 
the filename you specified.



Printing Articles
You can print any currently displayed article by using the Print command.    The article will 
print to the default printer currently being used by Windows.    If you want to change the 
printer that is used, you must change the default Windows printer in Windows Control Panel 
(see your Windows manual for more information).
Printing an article:
1) Open the article.
2) Choose Print from the File menu

or
Click the Print button on the Toolbar.

The article will immediately print to the Windows printer.
Note: The Print command is "context sensitive"; you can also use it while displaying a list of articles or 

newsgroups.    The currently displayed screen of articles or newsgroups will be printed to the default 
Windows printer.



Copying Information from Articles
You can copy information from a News article to other Windows applications by using the 
Copy command.    The information will be copied to the Windows Clipboard.    You can then 
paste the information into another Windows application (like Microsoft Word) by using that 
application's Paste command. 

With the article open, highlight the text you want to copy with your mouse and click 
Copy in the Edit menu (or click Ctrl-C)..    The text will be copied to the Windows 
Clipboard and will be immediately available to Paste in any Windows application.

You can also copy information from any other Windows application and paste it into News 
postings using the News Paste command.



Find
You can use the Find command, accessed by clicking Find in the Edit menu or by clicking 
the Find  button on the Toolbar, to find text in the newsgroup browser or the current 
newsgroup or article window.
In the Find What field, type the text you want to find.    You can check Match Case if you want
to match the case of the text you typed (otherwise, a case-insensitive search will occur).
Click the Find button to search; all the newsgroups or article headers that match will be 
displayed in the Results: dialog.    You can go to any of the located items by doubleclicking on
the item name or by highlighting the item and clicking Go To.



Decoding Files in News
Some articles that you will find in News are not actually articles; people will post shareware 
and freeware applications, graphics and sound files, and other binary files that they want to 
share with other USENET News readers.    These files are typically stored in newsgroups with 
the word binaries in the name; i.e. comp.binaries.ibmpc, or comp.binaries.pictures.    
Encoded postings are usually identified in the subject line as a program or graphics file, with 
subjects like "program.exe, part 1 of 3", "program.exe, part 2 of 3", "program.exe, part 3 of 
3".    
When you look at an article which is an encoded binary file, it will contain what looks like 
random ASCII characters (the article appears all garbled and incomprehensible).    Since 
Internet News only supports posting ASCII text, binary files must be uuencoded before they 
can be posted to articles.    This is a popular method used on the Internet to "convert" the 
binary file to ASCII so that it can be posted on the Internet.    These articles can be 
uudecoded so that you can convert them back to their original binary files.    News includes 
an automatic decoding feature which allows you to decode and view files like this that you 
find in News.
1) To decode a uucoded file, select any of the parts of the file by highlighting the article 

name with your mouse.    You only need to highlight one part of a file; News will locate 
the other parts of the file.    You can also decode several files at once, if you choose.

2) Click on the Decode button on the Toolbar or choose Decode from the Article menu.    
You will be presented with the <Save Decoded Articles> dialog, allowing you to specify 
where and how to save the decoded file.    Specify the target directory for the file(s) and 
any other preferences you have, and click OK.

3) The file(s) will be saved to the directory you specified.



Save Decoded Articles
The <Save Decoded Articles> dialog allows you to specify a location for the file(s) you are 
decoding.    Select the directory you wish to save your files to after they are decoded.
Other options are available in this dialog, as described below.

Overwrite existing files

The Overwrite Existing Files option lets you determine how you want News to respond when 
it decodes files with the same name as files that are already in the destination directory.
Replace existing files Files in the destination directory will be replaced, automatically.

Skip existing files A file will not be decoded if there is already a file with the same name in the 
destination directory.

Ask before replacing News will prompt you to confirm that you want to replace files in the destination 
directory.

Skip this dialog

You can determine whether or not you would like to see the <Save Decoded Articles> dialog 
during the decoding process.    Choose this option if you do not want to have this dialog 
appear every time you decode a file.
Note: If you select this option, News will save all decoded files to the last-specified destination. If you choose to 

skip this dialog, but later wish to change the destination directory, you can access the <Save Decoded 
Articles> dialog again by choosing Decoding from the Options menu.

Use status window

This option allows you to turn on or off the <Decoding Status> window.    Note that if you 
disable the status window, you will not be able to stop the decoding process.

View decoded files

This option allows you to have News try to open the decoded file using the application 
associated with the decoded file type.    Most files on news servers are sound or graphics 
files; you may want to immediately view (or play) the file.    News uses the associations from 
Windows File Manager to determine what application to use to open the file.    See your 
Microsoft Windows documentation for more information on associating files in File Manager.
For instance, if you try to decode a file with extension .BMP, News will open Windows 
Paintbrush and try to display the file.    The File Manager associates Windows Paintbrush with 
the .BMP extension.
News will automatically start the associated application and open the file.    You can then 
manipulate the file in that application just as you would normally.
Note: News will only open the first viewer associated with a file.    For instance, if you decode a zipped JPEG file (a

JPEG file with a .zip extension) and the .zip file type is associated in File Manager, News will launch the 
associated application, which will then allow you to unzip the file.    News will not, however, then open that 
file in its associated viewer (i.e. a JPEG file that has been zipped will not be unzipped and opened in 
ImageView).



Decoding Status
The <Decoding Status> dialog displays information on the current decoding session; this 
dialog can be useful for troubleshooting and tracking the decoding process.
By highlighting message text in the <Decoding Status> dialog box and clicking on the Copy 
button, you can copy and paste status messages. This feature is useful for discussing 
decoding problems with the creator of a file.    Clicking on the Clear button will clear all text 
from the dialog box.
You can stop decoding at any time by clicking the Stop button.    Note that this will stop all 
decoding; if you selected more than one file to decode, all the decoding will be stopped.
A common error message you will encounter in the <Decoding Status> dialog box will be 
"ERROR: Files missing."    This will occur when portions of an encoded file are missing (not 
present in the newsgroup).    There is no solution to this issue, but you could reply to the 
posting and ask the creator to repost the missing files.
Another common error will read: "ERROR: no viewer for xxxxxx", where xxxxxx is the path 
and filename of the encoded file you tried to decode.    If you receive this error, you don't 
have a viewer application associated with the file type.    The viewer application may be 
present on your system, but you still need to associate it in Windows File Manager.    See 
your Microsoft Windows documentation for more information on associating file types in File 
Manager.
You will see more error messages than those listed above.    They have been designed to be 
logical and easy to troubleshoot.    Most often, the errors you encounter while decoding a file 
cannot be resolved without asking the creator of the file to repost the file.
Warning: The subject line for a series of encoded articles must contain information 

specifying that the file is part of a series: either "xxxx" 1/5 "xxxxx" or "xxxx 3 of 
5 xxxxxx", where xxxx is extraneous file information (title, etc). Also, in order for
the auto-decode feature to work, the extraneous information must match for 
each file in a series; otherwise, SPRY News will not consider the files part of the 
same series.



 Posting Articles
You can post your own articles to a newsgroup if the newsgroup will permit it.
If you are posting an article in response to another article, you should use the Follow Up 
command.

Posting an article to a newsgroup:

1) Select the newsgroup you wish to post an article to by highlighting the newsgroup or 
reading one of the articles in that newsgroup. 

2) Choose Post from the Article menu
or
Click the Post button on the Toolbar.

You will see the <Posting> screen, allowing you to type the text of your article.    For more 
information on using this screen, click Posting.
3) Click Send to post the article, or doubleclick the Windows System menu in the upper left

hand corner of the screen to close this screen without sending the article.
Warning: There is no way to revoke or delete an article you've posted, so be sure your 

article is complete before posting!



Posting
The <Posting> screen lets you type an article to post to a newsgroup, as follows.
1) Type your article, using the standard Windows editing keys to move around the screen:    

Page Up, Page Down, the arrow keys, Home and End.
You can paste text into your article from another news article or from another Windows 
application.    You must use the cut or copy command in the other article screen or 
application, and then click Paste in the Edit menu to paste the information at the cursor
position.
You can also cut or copy any of the text you type in this article screen using the Cut and 
Copy commands in the Edit menu.    The text can then be pasted into other Windows 
applications using those applications' Paste command.
You can also attach binary and text files to your article.

2) Fill out the header information by clicking the Header button on the article screen 
toolbar.    The news header screen will appear.    This contains the information that is used
to post the article.
When this screen is complete, you can click Send to post the article.



Posting Headers
Fill out the Subject: field.    (This is very important.)    If you are posting a Follow Up article, 
the Subject field will be filled out for you; in this case, it is recommended that you not 
change this field, as it will help other people reading news follow the news article threads.
If the From: field is not yet filled out, you should also fill out this field.    
Some of these fields can be filled out automatically for you by News.    Choose Signature 
from the Options menu to customize these fields; they will then automatically appear when 
you post your article.



Attaching Files to an Article
You can insert ("attach") a binary file (such as a spreadsheet, word processing or graphics 
file) to your news article (or mail reply).    You can also have News automatically attach a text
file (a "signature" file) to every news article or mail message you create.    
____
See
Attaching a Binary File 
Attaching a Text File 



Attaching a Binary File
News automatically converts binary files to a format that allows them to be posted in a News
Article.    This process is called uuencoding the file.    The reader of the news article must 
have a uudecode program (a popular file decoding method) in order to convert the file 
back to its original format.    
You can automatically decode any uuencoded files that you find in News Postings; see 
Decoding Files in News for more information.
Note: You can attach a small file to your News posting without having to do any special conversion.    However, 

News articles have a size limit of 64K.    If the file you want to post is larger than 64K, you will have to use 
the UUCode program to split the file into multiple parts (use the comp.binaries format is recommended); you 
will then have to post each of the parts of the file up on News.    The USENET Newsgroup 
"alt.binaries.ibmpc" shows examples of multi-part encoded files.

1) In the <Posting>, <Follow up>, or <Reply> screen, click the Show Attachment button. 
An empty window will appear below your article text.

2) Click the Attach button.    You will see an <Attach File> dialog that you can use to 
navigate your directories and choose a file to attach.      Select the desired drive and 
directory and the filename that you want to attach.

You will see an icon appear for the file you attached. (You can choose Remove to remove an
attached file.)
3) When you have finished attaching the file, choose Hide Attachment to return to your 

posting screen, if desired.    You can post the article as you would normally, by pressing 
the Send button.    When you choose Send, News will begin attaching the file to the 
posting.    If the file is a text file, it should be attached quickly.    If it is a binary file, it may 
take some time to attach the file, as it has to go through the uuencoding process (as 
described above).    When the file is attached, the news article will immediately be 
posted.



Attaching a Text File
It is very common for news postings to contain a signature; some text at the end of the 
article that the author chooses to include in every article they post.    Signatures range from 
the formal to the goofy; containing address information, quotes, trivia, fun Internet links, 
etc., etc., etc.    They are usually from 1-5 lines.
You can create your own News signature, if you like.    This is known as an Auto Attach file; 
it is automatically attached to every news article you post (or e-mail reply you send).    
1) If you do not yet have a file to use as your auto attach file, create the file using a text 

editor.
2) Click Other in the Options menu.
3) For the Auto Attach value, specify the name and path for the auto attach file.    You can 

click Browse to browse your directory for this file, if necessary.
4) Click OK.    The Auto Attach file will be used the next time you post an article (or send a 

Follow Up or e-mail reply).



Following Up an Article
Following up an article is almost the same as posting a new article, except that the Subject 
of your article will reference the article you are currently reading, and the article text will be 
included in the body of your posting.
Following up an article:
1) Open the article.
2) Choose Follow up from the Article menu

or
Click the Follow up button on the Toolbar.

You will see the <Follow Up> screen, allowing you to type the text of your article.    For more 
information on using this screen, click Follow Up.
3) Click Send to post the follow up article, or doubleclick the Windows System menu in the 

upper left hand corner of the screen to close this screen without posting the article.
Note: There is no way to revoke or delete an article you've posted, so be sure your article is complete before 

posting!



Follow Up
The <Follow Up> screen lets you type an article to post to a newsgroup.    The text of the 
article which you were viewing when you clicked follow up will be included in the screen, 
with the > character at the edge of the screen to indicate that that text is from an earlier 
message.
You can complete this screen as follows.
1) Type your article, using the standard Windows editing keys to move around the screen:    

Page Up, Page Down, the arrow keys, Home and End.
You can paste text into your article from another news article or from another Windows 
application.    You must use the cut or copy command in the other article screen or 
application, and then click Paste in the Edit menu to paste the information at the cursor
position.
You can also cut or copy any of the text you type in this article screen using the Cut and 
Copy commands in the Edit menu.    The text can then be pasted into other Windows 
applications using those applications' Paste command.
You can also attach binary and text files to your article.

2) Fill out the header information by clicking the Header button on the article screen 
toolbar.    The news header screen will appear.    This contains the information that is used
to post the article.
When this screen is complete, you can click Send to post the article.



Replying to an Article
You can send an e-mail reply to the person who posted an article you've read.        This works 
just as if you were sending e-mail directly to the sender; you can add additional people to 
the addressee list (To: or CC: field), and change the subject line before sending the reply.
Replying to an article:
1) Open or select the article.
2) Choose Reply from the Article menu

or
Click the Reply button on the Toolbar.

A reply screen will appear, addressed to the author of the article you selected, with the 
same subject as the news article.    Change this header information, if desired.    For more 
information on using this screen, click Reply.
3) Click Send to mail the reply, or doubleclick the Windows System menu in the upper left 

hand corner of the screen to close this screen without sending the mail.
The article will be mailed to the person/people you indicated.



Reply
The <Reply> screen lets you type an email reply to someone who posted to a newsgroup.
You can complete this screen as follows.
1) Type your message, using the standard Windows editing keys to move around the 

screen:    Page Up, Page Down, the arrow keys, Home and End.
You can paste text into your message from a news article or from another Windows 
application.    You must use the cut or copy command in the other article screen or 
application, and then click Paste in the Edit menu to paste the information at the cursor
position.
You can also cut or copy any of the text you type in this article screen using the Cut and 
Copy commands in the Edit menu.    The text can then be pasted into other Windows 
applications using those applications' Paste command.
You can also attach binary and text files to your message.

When this screen is complete, you can click Send to send the message.



Using Personal Groups
News allows you to save different lists of newsgroups to Personal Groups so that you only 
access the groups you want to see.  Some sample Personal Groups are included with News; 
you can create your own Personal Groups, grouping newsgroups in any way you like.
The <Personal Group> screen, accessed by clicking Personal Group in the Window menu,
can be used to create, edit, open, and delete Personal Groups.
____
See
Creating New Personal Groups 
Opening Personal Groups 
Changing or Removing Personal Groups 



Creating a New Personal Group
1) Click Personal Group in the Window menu. You will see the <Personal Group> screen, 

listing any Personal Groups that were included with News.
2) Click New to create a new Personal Group.    You will see the Newsgroup Properties 

screen.    Fill out this screen with the name of the Personal Group.
3) Click OK to create the new Personal Group.

You can now add Newsgroups to a Personal Group.
____
See
Adding Newsgroups to a Personal Group 



Newsgroup Properties
This dialog is used to specify the name for a personal group (Description) and its location 
(Filename). 
You should specify a name for the Personal Group in the Description field.    This can be any 
name you choose.    
The Filename is optional; use this if you want to use a Personal Group that already exists.    
The filename for the Personal Group must be eight characters or less and contain no spaces 
(or characters illegal in DOS filenames).    If you want to search for a personal group, you can
click Browse; a dialog will appear, allowing you to locate any file.



Browse
This Windows Browse dialog allows you to browse and locate any file.    
You can select a file type from the List Files of Type box to display a list of all files with a pre-
determined type from the current drive and directory.
If you type a pattern using a wildcard (* or ?) in the File Name box and press [Enter], the list 
box displays files matching that pattern.
When you've located the file you want, you can doubleclick a filename in the list box to 
specify it.



Adding Newsgroups to a Personal Group
You can add newsgroups to a Personal Group using the Newsgroup Browser.    If the 
Newsgroup Browser is not yet open, you will need to open it    (use the Newsgroup 
Browser command in the Window menu).    You can then Subscribe newsgroups to a 
Personal Group, or drag and drop them into the personal group.
If the Personal Group is already open, it is easiest just to drag and drop the newsgroups into 
the Personal Group.
1) Select one or more newsgroups (use Shift when highlighting to highlight a series of 

newsgroups, or use Control when highlighting to choose non-consecutive newsgroups).
2) Drag and drop the newsgroup(s) into the Personal Group.
If the Personal Group you want to add the articles to is not yet open (or not yet created), it is
easiest to use the Subscribe command.
1) Select one or more newsgroups (use Shift when highlighting to highlight a series of 

newsgroups, or use Control when highlighting to choose non-consecutive newsgroups).
2) Click Subscribe in the  Newsgroup menu
The <Personal Group> screen will be displayed.    You should specify the Personal Group to 
which you want to add the highlighted newsgroup(s).
The Unsubscribe command will let you remove newsgroups from a Personal Group.



Unsubscribing Newsgroups
If you want to remove a newsgroup from your Personal Group, you can unsubscribe them, 
as described below.
Unsubscribing a newsgroup:
1) Select one or more newsgroups to unsubscribe by clicking on the newsgroup name with 

your mouse to highlight it.    You can select multiple newsgroups by using the standard 
Windows selection keys:    Holding down [Shift] while clicking on newsgroups will select a 
series of newsgroups.    Holding down [Ctrl] while clicking on newsgroups will select 
multiple newsgroups.

2) When you have chosen the newsgroups you want to unsubscribe to:
Choose Unsubscribe from the Newsgroup menu
or
Click the Unsubscribe button on the Toolbar.

The newsgroups you have unsubscribed to will be removed from the current Personal Group.



Opening Personal Groups
Once you have created Personal Groups, you can open them at any time from the <Personal
Groups> dialog by highlighting the Personal Group name and clicking OK.    The Personal 
Group will open in the News Console.    You can then read any newsgroups in it.    You can also
add and remove newsgroups from it.

Automatically opening Personal Groups:

You can open one or more Personal Groups automatically when you start News.    Open those
Personal Groups on your screen, and check the Save workspace on exit option in the 
Options menu.    When you exit and re-open News, the Personal Groups will open 
automatically.



Changing or Removing a Personal Group
You can change the location or description of a Personal Group by choosing Properties in 
the <Open Personal Group> dialog, and typing the new information.
In this dialog, you can also remove a Personal Group by highlighting the Personal Group 
name and choosing Delete.    This will permanently delete the Personal Group.



Exiting News
You can exit News by choosing Exit from the File menu or clicking the Exit button on the 
Toolbar.    You can also doubleclick on the Windows System Menu to exit News.



News Menu Commands
File menu 
Edit menu 
Newsgroup menu 
Article menu 
Options menu 
Window menu 



File menu
Connect
Disconnect
Change Server
Attach 
Save As 
Print 
Exit 



Connect
The Connect command allows you to immediately connect to a News Server.    You will 
connect to the News Server defined in the <Startup Options> dialog, found by choosing 
Startup Options in the Options menu.



Disconnect
The Disconnect command will immediately disconnect your current News session.    Any 
open articles and newsgroups will remain open in the News Console, but you will need to 
reconnect to the news server in order to open any new articles or newsgroups.
You can reconnect to the server by choosing the Connect option.    Alternately, you can just 
try to re-open a newsgroup or article; News will automatically try to restart your connection.
You can specify whether you are prompted before reconnecting to the news server by 
specifying Prompt on Reconnect using the Other option in the Options menu.



Change Server
The <Change Server> dialog, accessed using the Change Server command in the File 
menu, allows you to connect to a different News Server during your News session.
Type the News Server address you want to switch to, or select the option from the list that 
appears.    To add this address permanently to the list, click on the Add button.    To switch to 
the new News Server, check Connect Now and click OK. Your server connection will change, 
and you will be connected to the new server.



Attach
The Attach command performs the same as the Attach button in the Show Attachment 
window that appears when you Post, Reply, or Follow up an article.    Note that this option will
not be available unless you have clicked the Show Attachment button in those windows.



Edit menu
Cut 
Copy 
Paste 
ROT13
Find 



ROT13
Some articles in News contain somewhat questionable material.    In order to avoid offending 
readers caught off guard, text is sometimes 'scrambled' using ROT13 message coding, which
shifts each character 13 characters (an 'a' becomes an 'n', etc.).    
SPRY News includes a ROT13 coder/decoder.    To decode a message that is encoded using 
ROT13, highlight the text (it can be all or just some of a news posting) and select ROT13 
from the Edit menu.
Encoding articles with ROT13 is done the same way you would read articles encoded with 
ROT13: highlight the text in the posting window that you would like to encode), and select 
ROT13 from the Edit menu.



View menu
Sort By...
Sort Ascending/Descending
Tree 
List 
Toolbar 
Status Bar 



Sort By...
The Sort By... options in the View menu allow you to specify how news articles are 
displayed in the news article window.    Ordinarily, news articles are displayed with Author, 
Date, Lines (number of lines in the message), and Subject information.    You can choose to 
have News sort the articles using one of those options; it will sort in alphabetical or numeric 
order, as appropriate. 
You can choose whether to sort the articles in Ascending or Descending order, as well, by 
choosing the Sort Ascending or Sort Descending options in the View menu.    
Choosing Sort by Thread, on the other hand, will display the articles using Threading; the 
articles will not display the Author, Date, Lines, and Subject information.
____
See
Threading
Sort Ascending/Descending



Sort Ascending/Descending
You can specify the sort order for sorting news articles.    If you are sorting news articles by 
Author, Date, Lines, or Subject, you will be able to specify the sort order to use;
Sorting Ascending will sort alphabetically a-z, numerically 1-9
Sorting Descending will sort alphabetically z-a, numerically 9-1.



Newsgroup menu
Read 
Catchup 
Show All Articles 
Refresh 
Subscribe 
Unsubscribe 



Article menu
Read 
Decode
Send 
Post 
Followup 
Reply 
Previous 
Next 



Send
This performs the same function as the Send button in a News Post, Reply, or Follow up 
screen.



Options menu
Signature 
Startup 
Fonts 
Article Headers 
Toolbar Style 
Decoding
Other 
Auto Refresh 
Save Workspace on Exit 



Signature
This dialog lets you set up information to be used automatically whenever you create a Post,
Reply, or Follow up.    Filling out this dialog will mean that the header is automatically filled 
out for you with the information you specify.



Startup Options
News will connect to a default News Server whenever you startup News.    You can specify a 
different News Server to connect to by default by choosing Startup in the Options menu; 
the <Startup> dialog will appear, displaying the News Server that News is setup to connect 
to automatically.
Click Add to add another News Server address.    This can be an IP address (such as 
165.121.100.30) or fully qualified domain name (such as news.service.net).
News will store the name of the News Server you choose so that you can automatically 
connect to it in the future.    (You can delete any news server addresses by highlighting the 
Server name and clicking Delete.)
Note: You can also edit your hosts file to add News Server information; hosts file information will automatically 

appear in the list of News Servers in the screen above.    You may or may not have a hosts file on your 
system, depending on how your system is set up. 

You can also specify whether News should automatically connect to the selected News 
Server on startup.    If you use more than one news server, you may want to use this setting. 
Uncheck Restore Connection at Startup to not connect to any News Server on startup.
Note: You can disconnect from a News Server at any time by choosing Disconnect from the File menu.

News will now connect to that News Server whenever you startup News, if you specified 
Restore Connection at Startup, and will display that News Server as the default news server 
whenever you use the Connect command.    



Toolbar Style
The <Toolbar Style> dialog allows you to change the appearance of the Toolbar shortcut 
buttons.    You can choose between three different displays:    
Both Picture & Text, Picture only, or Text only.    
Click the appropriate radio button to select the Toolbar style, and click OK.    The Toolbar will 
change immediately.



Other
This dialog provides you with several options for configuring News:
Articles
You can specify whether you want to open the article window as a separate window from the
newsgroup window (the default value:    Open New Window to read article), or have the 
newsgroup window be replaced by the article window (Use Newsgroup window to read 
article).
You can also specify whether to open all article threads initially.    See Using Threading for 
more information.
Confirm on
Catchup
Open of caught-up Newsgroups
Both of these options indicate whether you want to be prompted during different events, 
when using the Catchup feature.    See Using Catchup for more information.
General
Prompt before Reconnect
This prompts you before reconnecting news, when your connection to a news server is lost 
for some reason.
Auto Attach File
This prompts you for the name of a text file to automatically attach to a Post, Reply, or 
Follow up.    See Attaching a Text File to an Article for more information.



Save Workspace on Exit
This command can be used to save your current News Console and options.    The 
Newsgroup Browser position, and any Personal Groups, newsgroups, and articles you have 
open or minimized in the News Console, will be saved.



Window menu
Cascade 
Tile 
Arrange Icons 
Close All 
Personal Group 



Cascade
Cascade all open windows (windows are stacked on top of one another).



Tile
Tile all open windows (all windows are displayed side by side).



Arrange Icons
You can minimize mail messages you are reading or composing.    
Arrange Icons arranges any minimized icons so that they are evenly spaced and do not 
overlap.



Close All
This will close all open windows, except the Newsgroup Browser window, which is always 
present.
 




